微信截图_20220520195312.png

更新1.2.0后出现的bug,放了好久一直没管,今天想起来打算解决掉,不想更新到最新的开发版,就自己翻代码尝试解决了。

打开/admin/index.php可以看到提示更新的信息是 JS代码请求/action/ajax?do=checkVersion获取的,搜索关键字checkVersion找到这个方法是在/var//Widget/Ajax.php中定义的,问题出在第62行version_compare($json['release'], $version, '>=')的判断条件上,
$json['release']是从官网获取的最新版本号,$version是本地版本号,两者是相同的,判断条件使用了>=导致函数返回结果为true,因此被误判为需要升级,删掉等号即可。

开始改之前没注意,这个bug在4月已经被人修了,只是没有打包到稳定版中,改完才发现:Fix checkVersion

改完之后仍然显示,按F12打开开发者工具 -> 应用 -> 会话存储空间,右击清除即可。

屏幕截图 2022-05-20 202027.png

标签: none

已有 2 条评论

  1. 热心网友 热心网友

    感谢朋友的精彩教程,我的也成功解决了!

    1. 很高兴能帮到你

添加新评论